Aug 282014
 

This dredded error message happens very rarely when using rvm. Sometimes a command provided by a gem or any execution to a ruby script (or a rake task) results in this error on the command line:

dyld: Library not loaded

Typically I’ve seen this happen when I have recently re-sourced my .bash_profile. Basically all that has happened is that rvm has lost an important link. There are two easy non-invasive fixes and a 3rd invasive fix.

1. Run rvm list, then switch to any other ruby install, then switch back to the ruby install you want to run.

2. If that doesn’t work, try switching out of your current directory and back into it.

3. If that doesn’t work, you probably want to implode rvm and install it from scratch. (this can be done with rvm implode, but sometimes this hiccups and you must remove it manually from ~/.rvm)